Abiquo Documentation Cookies Policy

Our Documentation website uses cookies to improve your experience. Please visit our Cookie Policy page for more information about cookies and how we use them.


Documentation

Skip to end of metadata
Go to start of metadata

Table of AIM versions and compatible versions of Abiquo

Abiquo version

AIM compatible version

Notes

1.8

1.3.2

 

1.8.5-HF6

1.4

 

2.0

1.4

 

2.0-HF5

1.4.4

Fixes bug ABICLOUDPREMIUM-4205 - If three VLANs get destroyed at the same time, one of the bridges does not get cleaned up

2.0-HF6 -
2.2 

1.5.1

Improvement ABICLOUDPREMIUM-4276 - Use aim.ini to define the list of valid datastore types. This version is compatible with Abiquo 2.0-HF6 and Abiquo 2.2

2.31.5.2

This version is backwards compatible with Abiquo 2.2 and compatible with Abiquo 2.3. Fixes bugs

  • ABICLOUDPREMIUM-4501 - Sometimes in a concurrent deploy on KVM, one VM is not deployed
  • ABICLOUDPREMIUM-4497 - Cannot delete a VM in KVM if its disk doesn't exist in the datastore.
2.41.5.3The detection of MOVE events is the responsibility of AIM instead of VSM (for KVM hypervisor). Compatible with KVM on CentOS 6.3. Upgrade to CentOS 6.3 from CentOS 5 requires VM migration.
2.62.1.4Compatible with CentOS 6.4. Abiquo recommends direct migration of VMs from CentOS 5 to CentOS 6.4. Upgrade to CentOS 6.4 from CentOS 6.3 requires VM power off.
3.0-RC12.2.1 
3.0-RC22.2.2 
3.0.0-GA2.3.0Fixes ABICLOUDPREMIUM-7526 - Memory leak detected
3.0.12.3.0Fixes ABICLOUDPREMIUM-7526 - Memory leak detected
3.12.3.0There are no changes to AIM in Abiquo 3.1. The compatible AIM version is AIM 2.3.0
3.22.4.2

The following new properties have been added to a new [stats] section to manage statistics for metrics and monitoring:

  • collectFreqSeconds = 60

  • refreshFreqSeconds = 30

  • database = /var/lib/abiquo-aim.db

3.2.22.4.3Fixes issue number 6016: Core count = CPU socket(s) * NUMA cell(s) * Cores x socket(s)
3.42.6.1
  • Adds support for 
    • multiple-disk templates
      • metric dimensions
3.4.22.6.3
  • renameDisk
3.62.8
  • Adds support for shutdown
  • renameDisk
3.82.8 

 

To check the AIM package information, run the following commands

[root@localhost ~]# rpm -qa |grep libvirt
[root@localhost ~]# rpm -qa |grep qemu
[root@localhost ~]# rpm -qa |grep aim